Issue deploying new application

Issues information

Having trouble deploying a new application. Keep getting the below error show up when I try to add the application. As far as we can tell the permissions have been setup correctly on Github. Qovery Github App has been installed and has access to all repositories.

Is there some other hidden permissions / settings we need to tweak to get it to work?

Have tried multiple different branches but none seem to work for this specific repo.
Also tried creating separate project and environment on Qovery.
Repo and branches do show up fine in the Create application modal.

Error message:
Cannot access the account of the provided git account: cannot get last commit id for branch master

Trying to deploy to this environment: Qovery Web Console | The simplest way to deploy your full-stack apps in the Cloud

Screen Shot 2022-07-12 at 2.20.59 pm

Screen Shot 2022-07-12 at 2.36.15 pm

Hello David,

I just tried with your account and I manage to create an application for mesa, and it works but only if I don’t use the branch master, all other branches beside master lead to be able to create the app.

Can you confirm me this on your side ?

Regarding the issue, I suppose this is coming from the force switch of github of the default branch from master to main.
If you can, rename your master branch on this repository to main.
To do that you can go in the settings

and let me know if it fix your problem.

If you can’t rename the branch, let me know, so I can try to find other solutions