Can not change Github connection from a removed team member


Recently we removed an organization member from our Github account and they had done the initial github integration. After the removal of the organization member, we can not deploy anymore as we are receiving the following error:

🚩 surein-live: Cannot find a folder in / in at commit 13a7ff8c742183297a5afca7157017e7e56f2aa4.Either folder does exist at specified commit or user 'xxx' does not have access to this repository anymore. You can change owner of the repository in the application settings

We then tried to update the Git repository settings in the Application Settings. We can “CHANGE” the github repo to someone else from the organzation but when we reload the page, the git repository is still connected to the removed member, thus we can not deploy.


The actual application id we are having this problem is: e21ad074-90c5-4730-8667-d61213f17eca


Hi @Bou ,

Do you use Qovery V2 or the Qovery V3 interface? If the URL starts with it’s the V2, if it starts with, then it’s the V3.

On the V2, once you changed your repository, did you “save” your changes?

Yes, we are pressing on the “Save” button. Then it says your application needs to be redeployed - which then ends up throwing the same error with a new deployment.

I actually just tried with v3 and it ended up being the same error.

Ok, one of our engineers take a look

could you share the Qovery console link to your app ?

Hello @Enzo

1 Like

@Enzo the link provided by Anxhina is correct, however this is the particular application we are having the problem: Qovery Web Console | Deploy and Manage On-demand Environments on AWS, Remarkably Fast

@Enzo @rophilogene I think we found a workaround - by forking our application on github to my personal account, then changing the repository on Qovery worked - I think when github repo is the same, connected account is not changing - probably this is a bug on your end.

Hello @Bou and @Anxhina , thanks for the link and the feedback.

We’re still investigating about this but it looks like a bug. We’ll work on a fix once it’s found.

Glad to read that you found a workaround. Please let me know if you need further help.