Delete error when AWS Resources are deleted from aws console

Issues information

  • OS: Alpine, Docker
  • databases: Redis
  • Programming language and version: NodeJS, ExpressJS, Python
  • Link to your project on Github/Gitlab: Private

Your issue

So after a successful test of my infra on Qovery, I was removing all other resources from AWS Console. I accidentally deleted the Auto Scaling Group created by Qovery. After this incident, all my AWS Resources (including Qovery and my others) were deleted.

Now I want to completely delete my Qovery Cluster + Apps so that I can do a fresh start. However, the application delete isn’t happening. I understand why this would happen, but how do I move forward from here? Is there a way to clean everything and do a fresh start here?

Hi @r4881t , you can try to prepare your infrastructure by running a cluster update via the Qovery web interface.

hello. I tried that, and it gives “update error”.

I ask one of our engineer to take a look - he will respond through this thread.


Deleting the Kubernetes node group did the trick. I’ve tried to update your cluster to re-update the nodegroups but encounter this issue:

AsgInstanceLaunchFailures: Could not launch On-Demand Instances. VcpuLimitExceeded - You have requested more vCPU capacity than your current vCPU limit of 32 allows for the instance bucket that the specified instance type belongs to. Please visit to request an adjustment to this limit. Launching EC2 instance failed

Can you please contact AWS support and ask to raise the limit to the one you need please.


1 Like

HI @Pierre_Mavro . I followed your advise and the AWS folks have upgraded CPU count to 132. I retried deleting and also updating the AWS Cluster. And it is still in error state. Could you delete this cluster from backend? I dont want this cluster or the env/apps on this

Can you please give one more try, it should be better. And if still do not work, please give me the name of the cluster and I’ll delete it.


1 Like

This worked great. When I logged in the console, the cluster was already running. I was able to delete the apps, envs and the cluster, which is what I wanted. Much appreciated. Thanls.

1 Like