BYOK AWS clean install helm error

I’m revisiting BOYK Qovery on EKS and I am starting with a clean 1.29 eks cluster. I have the default EKS addons installed (CoreDNS, kube-proxy, VPC-CNI). I’ve installed the EBS-CSI driver, EKS pod identity agent and karpenter.

I was following the install guide for EKS https://hub.qovery.com/docs/getting-started/install-qovery/kubernetes/installation-aws/

and I was using the default demo values for this initial test: qovery-chart/charts/qovery/values-demo-aws.yaml at main · Qovery/qovery-chart · GitHub

I set all the set-by-customer variable and then ran helm and it comes back with these errors:

❯ helm version
version.BuildInfo{Version:"v3.14.2", GitCommit:"c309b6f0ff63856811846ce18f3bdc93d2b4d54b", GitTreeState:"clean", GoVersion:"go1.21.7"}

❯ helm upgrade --install --wait --atomic --create-namespace -n qovery -f helm/qovery_values.yaml \
--set services.certificates.cert-manager-configs.enabled=false,services.certificates.qovery-cert-manager-webhook.enabled=false \
qovery qovery/qovery
Release "qovery" does not exist. Installing it now.
Error: unable to build kubernetes objects from release manifest: [resource mapping not found for name: "qovery-cluster-agent-tls" namespace: "qovery" from "": no matches for kind "Certificate" in version "cert-manager.io/v1"
ensure CRDs are installed first, resource mapping not found for name: "qovery-cluster-agent-issuer" namespace: "" from "": no matches for kind "Issuer" in version "cert-manager.io/v1"
ensure CRDs are installed first]

To double check my EKS setup, I ran this same helm config on my local rancher desktop with a clean k3s install and got the same errors.

To troubleshoot I installed cert-manager separately and was able to work around this initial issue and finally saw the qovery containers come up but now I’m seeing errors on the qovery cluster agent:

error: invalid value '*organizationId' for '--organization-id <ORGANIZATION_ID>': invalid character: expected an optional prefix of `urn:uuid:` followed by [0-9a-fA-F-], found `*` at 1  

I did double check my config from the qovery UI and downloaded it again to my helm values file.

Coming back to this, I did manage to get Qovery installed via helm. I grabbed the latest helm config values from the git repo as it looks like there has been some updates. I see now that you need to run Helm twice with the 2nd time to enable the cert-manager.
So the pods appear to be running now on my EKS cluster but ran into this error when I tried to run a simple container:

Hi @ks321 , could you please provide me your Qovery environment URL? Thank you

https://console.qovery.com/organization/16ea9b02-bd23-42bc-b21a-a489cf688dc4/project/030b2ff5-82c9-4d15-acbe-55c85c6ee07c/environment/ca4b94ab-eced-4253-94f6-e672527dde0b/services/general

Hi @ks321 , I think it’s due to our current limitation - the local container registry we deploy with your BYOK cluster is running in HTTP and not HTTPS - which probably leads to this failure. We are working on it, you could expect to have a fix in the coming days. I’ll keep you posted.