Unable to deploy - 403 Error accessing ECS


Relevant information to this issue:

  • OS:
  • databases: N/A
  • Programming language and version: Typescript Nuxt 3
  • Link to your project on Github/Gitlab: N/A
  • Link to your application - starting with Qovery


I tried deploying my app but I am getting a deployment error due to a 403 error accessing the built image from ecs. Not sure it is relevant but I can run the app using docker locally.


Describe step by step how to reproduce the issue
Run a deployment of the app.

Hi @bsimakis , can you please provide your Qovery web console url to take a look? Is it an app deployed via git or a container registry?


It looks the qovery user doesn’t have enough permission. Can you please check the permissions:


Hi @rophilogene, the link is included in my original post.

Deployed via Git with the Dockerfile.

Hello @Pierre_Mavro, I confirmed the qovery user setup and permissions match the page you provided. Here is the policy from the IAM console:

    "Statement": [
            "Action": [
            "Effect": "Allow",
            "Resource": "*"
    "Version": "2012-10-17"


The issue is now solved. The cause was an app responsible for pushing ECR credentials which were in bad shape (registry-creds). I restarted it and it’s now working.

Sorry for the inconvenience.


Thank you, that worked

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.