Unable to create alias

I am unable to create alias for a secret variable in v3 UI. Please look at attached screenshots. The issue is that the alias text box in Ui is read-only and I am unable to add/write any value into it.

I tried this on Safari Version 16.2 (18614. and Firefox 109.0 (64-bit) on MacBook Air M1, 2020

Hey @r4881t !

Just to understand, you want to edit value field for ALIAS?
If so, it’s not possible. An alias is just a new variable / secret pointing to another variable. It’s value is initial variable value.

As an example:

##type ##name. ##value
VALUE VARIABLE value_variable 1

Hi @bchastanier I want to create an alias for an already defined secret variable. So for this I went to the secret variable, kebab menu, clicked create alias, and then the field is not editable in the UI that opens.

Can if the ALIAS Variable field editable? It’s supposed to be the only field editable on this popup along with the scope.
On your second screenshot, your ALIAS name can be modified in the first field (text with red BG):

1 Like

Ah I see. I was trying the wrong thing. Thank You.

1 Like

Hi @r4881t ,

we are updating the interface to make it clear that you can only edit its name

1 Like

I tried the new interface and I loved it. No confusion. I really love the speed at which you guys push updates. Keep up the great work. @a_carrano

1 Like