Rules on Preview Environnement seem not working

Hi,

I have some rules to deploy preview environnement only if they match Preview in pr name but they seem not working

can you help me ?

It seem also the preview environnement don’t follow the “stop/start” rules is it normal ?

Hi,

Can you please give more info like:

  • The project name rule is applied
  • Expected preview name matching

Thanks

Hi,

i share you the project “staging” deploiement rules

  • Deploy staging (staging not my default cluster)
    – cluster: staging
    – Auto-deploy: ON
    – Auto-delete: ON
    – Start/Stop:
    – Target future environment:
  • AM
    – cluster: staging
    – Auto-deploy: ON
    – Auto-delete: ON
    – Start/Stop: 08h TO 11h
    – Target future environment: Preview
  • PM
    – cluster: staging
    – Auto-deploy: ON
    – Auto-delete: ON
    – Start/Stop: 14h TO 19h
    – Target future environment: Preview

Hi @Nicolas_Hernandez , we’ll take a look ASAP and come back to you

Hi @Nicolas_Hernandez ,

I had a look at your setup and there is an issue with the setup of your deployment rules.

As an example, if you are trying to achieve to automatically start and stop your preview environment from 8 to 10 you can set the rule to “Target future environment” = “[PR]*”

Why?
because each preview environment name starts with “[PR]”
Documentation here: Deployment Rule | Docs | Qovery

If you are trying to achieve a setup where the preview envs are automatically started/stopped between 8 to 11 and between 14 and 19 this is something we do not support. Only the first matching rule is applied and thus on your setup, only the AM rule will be applied

Documentation here: Deployment Rule | Docs | Qovery

We have improved a little bit the interface on the V3 but it still not perfect, we are working on making more easy to configure this type of setup automatically

Thanks for your anwser,

If i understand, i cannot control also which pull requests must have preview environnement or not ?
I try to switch “Target future environment” but all my pull requests create an preview environnement

Hi,

Unfortunately, this type of filter is not working with the deployment rules. We are working on revamping our deployment rules system and we should deliver the new version in Q1 that will allow this type of configuration and more (TTL etc…)

Hey @Nicolas_Hernandez ,

as a temporary workaround, if you are using a CI you can actually implement this filter in your pipeline via our CLI:

  • disable the preview option on Qovery side (To avoid duplicated envs)
  • implement your custom logic via an action that will call Qovery in order to clone/update/deploy the application you want to use within a preview env. You will also have to take care of the environment deletion once the PR is closed.

more info here for GitLab GitLab CI | Docs | Qovery