Logs impossible to read in my deployments


Describe your issue here

From this morning, when I deploy my app, the logs generated are not comprehensible.
Do you know what is the problem ?

Hello @Dan_Dray
Thank you for reporting the issue.
Iā€™m currently investigating the problem and will provide an update as soon as possible.


Thank you for your reactivity @Pierre_Gerbelot

It has been fixed.
Let me know if you still encounter the issue.
Thank you

Thank you, it worked again few hours after my message.

For our information, do you know what happened, and why we got a deployment error during this time, and afterwards the same deployment worked perfectly until the end ?
We thought something in the code/environment variables caused it but we saw that it worked well at the end

In one of the logs that was impossible to read, I see this error:

Error reading "config/database-config.js". Error: Error: Config validation error: "MICROSOFT_SSO_SPUERKEESS_CLIENT_ID" is not allowed to be empty

So I think the deployment error is due to this environment variable that has not been correctly defined.

The reason why the log was impossible to read was linked to a bug in our obfuscation system. This has now been corrected.


1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.