Helm Service Successfully Deployed but No Application in Overview Tab

INFORMATION

Relevant information to this issue:

  • Link to your application - Qovery

ISSUE

I was testing out the new Helm Service feature and I tried deploying a Kubecost chart. The deployment was successful. I even verified that all the resources were deployed via kubectl. I also confirmed that the kubecost analyzer is working and accessible by doing a kubectl port-forward and accessing the service on my local machine.

My concern is I want to access the service via Qovery console provided link. The problem is the Overview tab of the Kubecost Helm Service is empty

Need your help on this. Thanks!

Hello @aedcparnie !

From your helm chart settings, it seems to miss the global: key leading to service annotation not being present hence Qovery agent not seeing this service as running.

You should have something like that:

Also, it seems you set the token in the YAML directly, but this (values) won’t be encrypted on our end, so we strongly advise you to use secret variables for it.
Add a secret KUBECOST_TOKEN and set kubecostToken : qovery.env.KUBECOST_TOKEN

We are updating our Kubecost installation guide, we will share the link here :slight_smile:

Let me know if it helps.

Cheers

Hello @bchastanier

Good catch. I’ve followed what you said and added the Kubecost token in a secret variable as well. The deployment is still successful but unfortunately there are still no Applications showing on the Overview Tab of the Kubecost Service

UPDATE:
Tried deleting the helm service, re-created it (https://console.qovery.com/organization/becf1ce7-d027-4cbe-a1a6-2ce4e7559238/project/07c6f296-55e4-4387-af3c-651182133626/environment/e8d86ee4-f586-4df6-98f7-d5031b3a128f/application/25386a69-be7d-4ac1-9cb2-f2f27dd94394/settings/networking) and it worked. The remaining problem is that I still can’t access the application via the provided Service Link/URL

Ok ! So just made it works. Issue was around ports, I removed it all and recreated and now everything is working :slight_smile:

Let me know if it’s ok on your side.

1 Like