Deployment error: "invalid or unknown remote ssh hostkey"

Hi, I’m having trouble deploying new versions of our services, deployment fails immediately after the cloning step.

Cannot build Application "xxx" due to an error with git: Error { code: -17, klass: 23, message: "invalid or unknown remote ssh hostkey" }

Deployments on the same services were working perfectly yesterday. It occurs to me that it may have something to do with git submodules. We haven’t changed anything in that regard though, SSH keys and repos are unchanged.

Hope you can fix it soon, we have bug fixes to deploy :pray:

Hello @s.aranguiz

You mentioned submodules, where do those sub-modules point to? Is it hosted on Github as well?
Did you used GIT or HTTPS to register those sub-modules?
If you used Git, do you mind register those using HTTPS?


Hi @bchastanier, both sub-modules point to Github, we use git with GIT_SSH_ env vars (they are private repos).

This setup worked perfectly for months on Qovery until yesterday. I worked around this problem by making both sub-module repos public and using HTTPS, this is far from ideal of course.

Hey @s.aranguiz,

I am not sure if it might relate to this one We updated our RSA SSH host key | The GitHub Blog, it’s weird it appeared only yesterday though …
We will have a closer look on our side and keep you posted.