Deploying my python app via web console fails

Issues information

Your issue

I recently discovered qovery via a post on reddit and used the free plan to run my Discord bot, which I am in the process of completely rewriting. Due to some logics I restructured the repositories I use for it, which involved the bot core repo moving to a subgroup.

I couldn’t find the proper way to edit the app I initially set up, so I decided to remove the project and recreate it. Now I am stuck fighting with the web console throwing an error of “0 Unknown Error”, the project repo history is pretty goofed up with a series of qovery commits, and nothing happened.

-EDIT- Been trying some simple things to further narrow down the issue, tried disabling my AdBlocker/PrivacyBadger, switched browser, and tried from my laptop tethered to a hotspot. On the last point, I caught a glimpse of the error message again, and it seems that the console fails to communicate with the API, claimng a “HTTP Failure message” with the error code mentioned above.

Dockerfile content (if any)

Link to Dockerfile on Gitlab

Hello @Kaltenstein23, indeed I see your project but I don’t see any environments deployed, or even errors. Could you please push a new commit to your repository and try to deploy it one more time?

That is the problem, I’m trying to deploy an initial environment. And it fails after a few minutes of showing a spinner on the deploy button.

I am not in the range of a laptop or desktop, but will make a video illustrating my issue if it helps understanding.

While not being a video, this is what happens when I hit “Deploy”. Apologies for the phone picture, but I’m still traveling for an hour or more.

No worries, quality is good enough.

I see we have problems fetching the.qovery.yml file from your repository. Could you please create a Qovery config file in your repo? (we are gonna get rid of this file in the next major update, it won’t be required anymore).

Here’s a link to the documentation page - Applications | Docs | Qovery

There is one already. In fact, it gets recreated with every time I hit “Deploy”. Which is one of the reasons I initially posted here… It commits the file fine then, but cannot read from it?

Commit History -

File in question:
.qovery.yml in Repo

So, I tried to create an application with a fresh copy of the master branch, added a .qovery.yml as detailed by your linked guide and it still did not work. I’m kinda stumped now.

The only thing I’m getting now is errors about a request being denied due to CORS headers missing

Access to XMLHttpRequest at '' from origin '' has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource.

in the browser console

Could it be a possibility that it hiccups on the repository being in a subproject? Because that’s the only thing that actually changed between my test application and this.

Did you get a solution for cors issue?

you need to enable cors in the backend application to avoid cors error

1 Like