Default backend - 404 . . not sure how to solve it

Issues information
when trying to access the front-end of the app I receive this error [default backend - 404]
I am not sure how to solve it

  • OS:
  • databases: N/A
  • Programming language and version: Node JS latest
  • Link to your project on Github/Gitlab: Github

Your issue
when trying to access the front-end of the app I receive this error [default backend - 404]
I am not sure how to solve it , I spent two days trying to reply and redeply but no success
Describe here your issue

Dockerfile content (if any)

specify here your dockerfile content No Dockerfile

here is my qovery yaml
`application:
name: “connector”
project: “connectorenv”
organization: “QoveryCommunity”
publicly_accessible: true
port: 3003
routers:
custom_domains:

  • branch: “master”
    domain: “ioioio.ioioi.com”
  • name: “connector”
    routes:
    • application_name: “connector”
      paths:
      • “/*”`

Hello. .qovery.yaml is not needed anymore for the V2. If you’re deploying in V1, you should move to the V2 as soon as possible as the V1 is getting shut down in 2 weeks. After that’s done, make sure you’re configuring the correct port in the Qovery settings by going to settings, port, then checking there.

I can access the domain you have specified, but it includes some Chinese characters, so definitely not an error.

Please let me know if you’re still running into trouble.

what do you mean by V1 and V2?
I am not sure on which I am
also the domain I added just for clarification, I haven’t thought there is a website with this domain :slight_smile:

I just confirmed it is V2

my problem still exists and I tried to change the port from the settings, and looks like this page is not working also

The team is looking into similar issues with other people. cc @rophilogene

1 Like

I have assigned this issue to @Pierre_Mavro and @Erebe - they will take a look in a few hours. Thanks for your patience :pray:

Hello Mars,

Can you give me the url of your environment so I can take a look please ?
It Is the one that start by console.qovery.com

Thanks :slight_smile:

Hi, I removed the domain this is the puplic link https://zc055f61a-gtw.qovery.io/
yes this is the url I am using console.qovery.com
assingin port is also not saving I receive failure msg

Regards

Hello,

I was asking for this url from the console.qovery.com

The full one with all the path and uuid :slight_smile:
It is going to help to see your configuration without bothering you too much, so I can investigate

here is the link.

thanks in advance

platform/organization/e4729440-f327-4662-8b1b-31aef18405f1/projects/4dcae233-70e4-4b57-a1c3-817fe1b6c9a5/environments/64c70987-afe3-4110-8123-49b41272f937/applications/c055f61a-dc96-43c4-a694-0977d94298db/summary

this is the msg I receive when I set the port

Hello,

Sorry for the late response, after investigating your case it seems we have a regression with custom domain in the V2.

It is going to be fixed tomorrow or next week if time is short.
I am going to keep you updated regarding the evolution.

Sorry for the inconvenience

thanks , how about the port issue

I managed to add it without any issue this morning.
Have you changed something ?

I just added the domain
The only problem I have is defaultbackend 404
I am not sure how to solve it
I uploaded the code on heroku on a2hosting
It is working fine there I am not sure why it’s not working here

It seems that you are getting a 404 default backend, because your app is running properly
and is crash-looping

(node:26) DeprecationWarning: collection.ensureIndex is deprecated. Use createIndexes instead.
(Use `node --trace-deprecation ...` to show where the warning was created)
Mongoose: invoices.ensureIndex({ invoiceNumber: 1 }, { background: true })
Mongoose: products.ensureIndex({ sku: 1 }, { background: true })
Mongoose: contacts.ensureIndex({ contact_id: 1 }, { background: true })
Mongoose: purchase_orders.ensureIndex({ invoiceNumber: 1 }, { background: true })
node:internal/process/promises:246
          triggerUncaughtException(err, true /* fromPromise */);
          ^
[UnhandledPromiseRejection: This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). The promise rejected with the reason "#<Object>".] {
  code: 'ERR_UNHANDLED_REJECTION'
}
npm notice
npm notice New minor version of npm available! 7.19.1 -> 7.20.0
npm notice Changelog: <https://github.com/npm/cli/releases/tag/v7.20.0>
npm notice Run `npm install -g npm@7.20.0` to update!
npm notice

@Erebe
the code is working fine here https://test.takweentech.com
you can check it, also I tried it on Heroku it is working
but on the qovery I am not sure why is this error is happening in the first place, and I believe it is not from the code

moreover I tried to host another app that is working locally and heroku and got the same error

Hi @Mars-2030 ,

Are you sure you’re using the same commit on Heroku and Qovery?

Because here, from logs of your app shown by @Erebe , we can clearly see the issue is code side.

in your images, i can’t see if your app is deployed, if not, you need to deploy it, and check if you have credits for it. version 2 works on a credit basis.