Default backend - 404 error with custom domain

Issues information

  • OS: Chrome & Firefox on Mac
  • databases: n/a
  • Programming language and version: Dockerfile
  • Link to your project on Github: analythium/shinyproxy-demo

Your issue

Describe here your issue

I could add the new app based on the Dockerfile and all works fine with the subdomain: z502fb459-ze8ec7a30-gtw

I added a CNAME to my DNS pointing to this subdomain, but when I visit the URL ( it shows default backend - 404. I have waited patiently for the DNS to propagate, but no improvement over 2 days.

Dockerfile content (if any)

FROM rocker/r-base:latest

RUN apt-get update && apt-get install -y --no-install-recommends \
    sudo \
    pandoc \
    pandoc-citeproc \
    libcurl4-gnutls-dev \
    libcairo2-dev \
    libxt-dev \
    libssl-dev \
    libssh2-1-dev \
    && rm -rf /var/lib/apt/lists/*
RUN install.r shiny intrval
RUN echo "local(options(shiny.port = 3838, = ''))" > /usr/lib/R/etc/
RUN addgroup --system app && adduser --system --ingroup app app
WORKDIR /home/app
COPY app .
RUN chown app:app -R /home/app
USER app
CMD ["R", "-e", "shiny::runApp('/home/app')"]

Did you try restarting your application?

1 Like

At the moment, redeployment/restart of application is required after adding a custom domain