Cannot fetch chart dependencies

Hi,

We’ve tried installing this helm chart but we get this error:

Error: no repository definition for https://grafana.github.io/helm-charts, https://grafana.github.io/helm-charts, https://grafana.github.io/helm-charts, https://prometheus-community.github.io/helm-charts, https://prometheus-community.github.io/helm-charts, https://prometheus-community.github.io/helm-charts, https://prometheus-community.github.io/helm-charts, https://opencost.github.io/opencost-helm-chart. Please add the missing repos via 'helm repo add'
Error while creating template: "grafana-k8s-monitoring": "Cannot fetch chart dependencies: CmdError(\"helm-zf3193325-grafana-ks-monitoring\", DEPENDENCY, CommandError { full_details: None, message_safe: \"Command terminated with a non success exit status code: exit status: 1\" })"

We tried adding the listed Helm repos to Qovery but it didn’t fix the problem. Is helm dependencies supported? Is there something we need to configure differently?

Hello @prki
I’m taking a look at the issue.
Regards

1 Like

We are working on a fix. I will let you know once it has been deployed.
Cheers

Hello @prki
A fix has been deployed.
Let me know if you encounter any issues.
Thank you

1 Like

Thanks @Pierre_Gerbelot, the installation moved forward but we encountered another issue:

💀 Failed to get an answer from the engine in 10 min, aborting deployment. Please retry later !

We increased helm timeout to 20min but it’s still failing with the same message. Could you take a look at this helm deployment?