TCP is not a valid PortProtocolEnum


When I run the command in my terminal

qovery application env list -n "myapp" --show-values

I get all the environment variables, but when I execute the same command with Docker




COPY . .

ENTRYPOINT [ "/bin/sh" ]


set -e

qovery application env list -n "myapp" --organization myorg --project myproject --environment myenv --show-values

I get the error Error: TCP is not a valid PortProtocolEnum



docker run --platform linux/amd64 \
  -e QOVERY_CLI_ACCESS_TOKEN=xxxxxxxxxx \
  qovery-env-show \

Hello @moisesrodriguez

I can’t reproduce your issue. When I did it on my side, I had no error.


Hi @Pierre_Gerbelot,

Interesting. I keep getting the error. Could it be something in my setup? It’s not the first time I see that error, in this topic Environment Preview Cloning Error I got the same error.

Right now that error is stopping me from having preview environments. Since I have my services communicate via HOST_INTERNAL and on top of that, one of my services is private, so the only way to communicate is internally via HOST_INTERNAL. What I want end up doing is this:

set -e

APP1_URL=$(qovery application env list -n "app1" --show-values | grep "HOST_INTERNAL" | grep "BUILT_IN" | grep "app1" | awk '{print $10}' 2>&1)

APP2_URL=$(qovery application env list -n "app2" --show-values | grep "HOST_INTERNAL" | grep "BUILT_IN" | grep "app2" | awk '{print $10}' 2>&1)

APP3_URL=$(qovery application env list -n "app3" --show-values | grep "HOST_INTERNAL" | grep "BUILT_IN" | grep "app3" | awk '{print $10}' 2>&1)

echo '{
  "APP1_URL": {
    "sensitive": false,
    "value": "'$APP1_URL'"
  "APP2_URL": {
    "sensitive": false,
    "value": "'$APP2_URL'"
  "APP3_URL": {
    "sensitive": false,
    "value": "'$APP3_URL'"
}' > /qovery-output/qovery-output.json

echo "shell script executed successfully with output values - check out your Qovery environment variables :)"

But I can’t get past the error.

Also, I want to use it for adding a comment in the pull request, with the public domains for the services that have it with:

qovery application domain list -n "myapp" 
Id                                   | Type            | Domain                                         | Validation Domain                        | Generate Certificate
5f1a933e-f35c-4b70-adc3-e879fcd7190d | CUSTOM_DOMAIN   |         | | true

qovery application domain list -n "myapp" | grep "CUSTOM_DOMAIN" | awk '{print $6}'

Still stuck with this error

Would you mind sharing your cli version and the url of your application/service ?

Sure, this is console url and the CLI version I use in the Dockerfile

Ok, that’s why. We don’t publish anymore the cli in a docker container.

Please use directly the binary from the release section Release v0.84.3 · Qovery/qovery-cli · GitHub or install it via our helper CLI | Docs | Qovery

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.