Scaleway container registry

Hello, I am new here, considering to use Qovery in production for my company. We are trying to split our monolothic app into micro services without spending too much time on OPS task. Qovery seems clearly to be a good candidate :slight_smile: .

We struggling while trying to deploy our first app from our container registry.


  • Browser: Firefox
  • Console version: V3
  • Container registry provider: Scaleway

After having configured our k8s environement & our image registry on Qovery app, we’re trying to deploy a new service from a published docker image and we are facing an error.

I suspected the way we named our image organization/image_name:tag was involved, but I have the same error with a simpler name which is:

Any idea why is this happening ?


  • Configure a scaleway container registry at organization level scale
  • Publish a private docker image on registry with a tag (ie. poulpus/internal-docker:1.6.0)
  • Try to deploy a new service from configured container registry with published tag

Hello @qvdp !

Would it be possible to share your qovery console link so we can have a look?

Thanks :slight_smile:

Hello @bchastanier thanks for your fast reply, are you meaning this link ? Or the one with the logs from my env ? (which are empty atm.)

Also, I have tried to configure both ways:

1st scenario:

  • In registry configuration URL: ${SWC_URL}

  • In image deployment: ${SCW_NAMESPACE}/${IMAGE_NAME}

2nd scenario:

  • In registry configuration URL: ${SWC_URL}/${SCW_NAMESPACE}
  • In image deployment: ${IMAGE_NAME}

Ok. just tried to recreate another registry from scratch, it is now working. Their might have been an error the first time I have initialised our scaleway CR

Oh ! ok, you were faster than me testing :slight_smile:

Glad you are good now !

Please let us know if you need further assistance.

1 Like