Public URL not showing in v2


I’ve migrated my app to v2. But I don’t see the auto-generated public url anywhere in the UI.

How can I find it? I tried also with the API but it’s not showing it anywhere. I can only see the custom domains.

Thanks in advance!

Have you tried Action → Open in the application?

Is it just me or I don’t see Open option in here:

Are you talking about a different Action → Open menu?

This looks like a DB app interface, did you try it under your main app (the buildpack or Docker one) Actions? You can also find it in your deployment log somewhere at the bottom, something like:

20 Jul, 09:30:50.376
Let's check domain resolution for ''. Please wait, it can take some time...

I deleted the whole app and created it again making sure it is Application and not DB (I was sure it wasn’t a DB before but just to be on the safe side). I changed the Buildmode to be Dockerfile this time instead of Buildpacks. App was deployed successfully and I still don’t see the Actions → Open button and in the Show Logs menu I don’t see the line that you posted above. I only see my app’s logs.

Not sure what is going on but my impression is that v1 was more stable.


You need to declare a port in Application > Settings in order for the open menu to appear and to have an application reachable from the internet.


Thanks @Erebe, that’s definitely good to know. I have defined PORT in my env variables but it looks like it’s not enough to be only there.

I added it and now at least I get the Actions → Open and the public url.
But now I get “default backend - 404” when clicking on the url :grinning:

Can you give me the URL of your application so I can take a look of it please ?
(the one from your browser, starting by

Here it is

Here you go, is working, I just forgot to tell you that you need to re-deploy your application once you add the port.

Thanks a lot @Erebe !