I dont know why its error?

I can build the docker on device and run the system

can you show your Dockerfile and app settings you set in Qovery console

Same issue, I set the expose in dockerfile, but not work… see below my dockerfile

FROM node:14-alpine
RUN apk update && apk upgrade &&
apk add --no-cache tzdata

RUN mkdir -p /home/node/app/node_modules && chown -R node:node /home/node/app

WORKDIR /home/node/app
COPY package*.json ./
COPY . .
COPY --chown=node:node . .
USER node
RUN npm install
CMD [ “node”, “index.js” ]

In my computer it’s working


@Erebe can you take a look at this

Have you specified your port in the app settings too?

No, only on Dockerfile, in past, this same deploy worked well, I deleted the project, and .qovery.yml and make the redeploy, but I had same issue

Specify a port in the app settings. V1 and V2 are different in how they manage ports. In the V2 you need to go in the app settings and specify the port you want to open.

Can you share a how to set this ports on app settings? I’m using v1 now

V2 supports opening port from app settings, in v1 you need to setup the port in Dockerfile

I’m return to V1 because I can’t save settings after set a port number, I’ll create a new topic with this

v1 will shut down for community users soon, so you should use the v2
you can find the tutorial on how to deploy node express app on Qovery in this community call recording. and how to setup ports

V1 is slightly complicated as you need to specify the ports in both the yml file and on your dockerfile. For the V2, it’s as simple as going to the app settings, then port, then specify your port. I can’t help you with the V1 as it’s getting deprecated and users should move to the V2.

Save button does save your config but doesn’t have any feedback. Rest assured, your port config is getting saved normally, just click out of the window.