Networking ::: Can't connect to app's HOST_INTERNAL using Twingate


Relevant information to this issue:

To manage access to internal resources I use Twingate and I have Twingate up and running. Twingate connector is in the same environment running as all the apps/resources that I want to connect to. At the moment I have my database as private and I can connect to the database through the Twingate Tunnel with no problem.


But when I want to connect to a private application I can’t reach it

Is there something network-wise that is different for applications than for example the database that I can connect to? Or is there something I’m missing that I can’t see yet?


Describe step by step how to reproduce the issue
Setup Twingate and try to connect to application.

Hello @moisesrodriguez ,

I’m checking

Hello @moisesrodriguez,

After checking on my side with a twingate account, I succeeded to configure an application successfully by using the service name, which is of the form servicename.namespace.svc.cluster.local

As you have 2 ports defined in your application ist-db, you must include the port you want to target when you’re doing the request => servicename.namespace.svc.cluster.local:YOUR_PORT

Hi @Melvin_Zottola,

Can you guide me to what should I use for servicename and namespace? I’ve already connected to my k8 cluster and ran kubectl get namespaces and used the options there as namespace, but none of them seem to work. I’m probably not using the correct values. For servicename I’m using the name of my app as shown in the qovery console.

Hello @moisesrodriguez

Sorry I didn’t see your answer before today.

About the config here is what I can show you:

  • I have deployed the helm chart of twingate, and one service exposing 2 ports (but declared as private on Qovery side). Please note that you can declare only 1 port, I just reproduced the same config as you had at first.

So in the following example, I’ve declared the resource on Twingate console as app-z02659c45-httpgo.zc3d57493-twingate.svc.cluster.local

And as my server is listening on 3000 and 2000 ports, I can access my resource by specifying the wanted port, e.g http://app-z02659c45-httpgo.zc3d57493-twingate.svc.cluster.local:2000/

Hope this will resolve your issue,

Have a nice day

@Melvin_Zottola That works! Thanks!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.