Managed Redis env vars use non-SSL protocol

Redis URLs provided by Qovery as env vars start with redis://, the correct one needs to start with rediss:// (SSL connection) for the generated managed instances (haven’t tested container ones).

Qovery team please fix the Redis URL env var protocol :pray:

Hi @s.aranguiz , thanks for reporting this. I forward to our engineering team.

Hello @s.aranguiz ,

Do you mind giving more details about your config / stack? Do you you an ORM (if yes, which one)?

We had a similar case couple weeks back, adding an option made the trick: Failling to connect to Redis Managed

Thanks,

Hi @bchastanier, we use an ElastiCache Redis 6 cluster (provisioned on the Qovery console). We connect to it using ioredis v5 on Node.js, and redis v4 on Python.

Given that Qovery provides an env var DATABASE_URL_INTERNAL, we expected to be able to connect to it using it without modifications, however, since the cluster only seems to accept SSL connections, this wasn’t possible.

redis://[username]:[password]@[QOVERY_INTERNAL_HOSTNAME]/0

In the end, we had to provide the connection URL manually setting the Redis SSL protocol rediss, and the full cluster hostname:

rediss://[username]:[password]@master.[QOVERY_INTERNAL_HOSTNAME].xxx.use1.cache.amazonaws.com:6379/0

Using the Qovery internal hostname fails with a TLS error using ioredis v5 on Node.js:

Unhandled error event: Error [ERR_TLS_CERT_ALTNAME_INVALID]: Hostname/IP does not match certificate’s altnames: Host: [QOVERY_INTERNAL_HOSTNAME]. is not in the cert’s altnames: DNS:*.[QOVERY_INTERNAL_HOSTNAME].xxx.use1.cache.amazonaws.com

Hello @s.aranguiz,

Thanks for all the details here.

Actually, it’s a known issue on our end. We have a solution to be implemented and should be prioritised soon.

Sorry for the convenience here.

Cheers