Errors in deploying a dockerised python app

Issues information

  • OS: Windows 11
  • databases: redis (was not added)
  • Programming language and version: Python 3+
  • Link to your project on Github/Gitlab: GitHub TeamUltroid/Ultroid.

Your issue

It is a python project, which i’m trying to deploy using a docker.

  • Execution ID: d1e38062-836f-4e43-92df-4e37e63a8455-16-1626352966
  • Scope: Application ‘ze7046866’ with id ‘ze7046866’
  • Rollback message:

I was asked to create this here, for help, by the support chat.

Dockerfile content (if any)

Can be found here.

FROM programmingerror/ultroid:b0.1

ENV TZ=Asia/Kolkata
RUN ln -snf /usr/share/zoneinfo/$TZ /etc/localtime && echo $TZ > /etc/timezone

RUN apt install jq netcat -y
RUN apt autoremove

RUN git clone -b dev /root/TeamUltroid/

WORKDIR /root/TeamUltroid/

RUN pip uninstall search-engine-parser -y

RUN pip3 install --no-cache-dir -r requirements.txt

CMD bash resources/startup/

Hi @xditya :wave:, can you run your app in local with your Dockerfile? docker run | Docker Documentation

Yes, it works.

docker build . -t ultroid
docker run --env-file .env --rm -i ultroid

works fine on my local machine.

@xditya, from what I see in your Qovery app config - you didn’t your app settings to use Docker build mode (you were using Buildpacks). I changed it for you. Can you try to restart your app?

ohk sir, i’ll do that and update you :slight_smile:

its the same error again, and ig it was set to docker earlier too :sweat_smile:

Are you sure the port is 6969 ?

I see this error from your app

 e[31;1mERROR: e[0mfailed to launch: determine start command: when there is no default process a command is required

It looks like the problem is coming from this line in your Dockerfile.

CMD bash resources/startup/

okay. ill try changing that and running the file directly, and would update the outcome here…

okay, it seems like using CMD bash resources/startup/ was the issue.

i changed it to directly run the file, i.e, to CMD ["python", "-m", "fileName"], and that worked fine!

thanks for the help @rophilogene !

1 Like

Yeah :muscle: well done @xditya

1 Like