Disable IMDSv1

I have an issue with the Cluster Advanced Settings

As described here, I want to disable IMDSv1 on EC2 instances

I changed the setting to “required” as explain in the documentation, to have v2 instead of v1, and redeployed the cluster

But when I check on my EC2 instances, it seems to be v1, not v2 (optional tokens)

    "State": "applied",
    "HttpTokens": "optional",
    "HttpPutResponseHopLimit": 1,
    "HttpEndpoint": "enabled",
    "HttpProtocolIpv6": "disabled",
    "InstanceMetadataTags": "disabled"


Did you redeploy your cluster to apply changes?


Yes I did, 2 times to be sure

Can you please provide the Qovery console link to your cluster?



Thanks, I’ve found the bug. I’m going to make an update in the day. I’ll let you know when it will be released.

Thanks for reporting the issue. The fix is done, your cluster has been updated and IMDSv2 set as you wanted.


Thanks a lot !


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.