Cluster Deployment Failure


I’m new to trying to deploy a cluster so please bear with me.
I set up my AWS per the Qovery documentation and long story short - the deployment is failing with the following errors: is still not ready: PortNotOpen. retrying…
Kubernetes API cannot be reached.

I don’t have a link to the cluster because it was never deployed.

Thank you!

Hi @Eddie_Gonzalez , could you please provide your qovery web console? Then we can take a look :slight_smile:

Hi @rophilogene, here’s the link: web console

I deleted my initial attempt and tried again, same error.


Hi @Eddie_Gonzalez ,

we have found an issue on the K3s installation process and we are currently investigating it

1 Like

Hi @Eddie_Gonzalez,

There is indeed a regression on our end, it’s due to cluster advanced setting aws.eks.ec2.metadata_imds now defaults to required where it was optional.

We are working on a fix which should land anytime today or tomorrow.

In the meantime, you can change the setting in your cluster, it will solve the issue:


And fix has landed, EC2 cluster creation is ok now, sorry for the inconvenience.

Let me know if you need anything else.

Thank you @bchastanier. I’ll give it a try soon and let you know if I have any further issues.

Much appreciated,



This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.