BUG - Can't create applications with container registry source

I’m trying to move my applications to use an ECR container registry rather than pointing them at a git repository. Setting this up has been working just fine all week, until it stopped working today. When I try to set up the application, I can choose my registry and enter the image name, but then it spins for a while and errors out before I can select a tag:

Typing a tag into that box doesn’t help, even if the tag exists.

In the browser dev tools, I can see that it’s trying to get the images like this:


which keeps returning errors like this:

    "type": "about:blank",
    "title": "Bad Request",
    "status": 400,
    "detail": "Cannot fetch image grayce_api: getImageTags(...) must not be null",
    "instance": "/api/organization/XXXXXX-0b18-45c5-9c33-6f1981bc70ff/containerRegistry/XXXXX-764d-41ea-8fbd-295a3199f4b6/images",
    "message": "Cannot fetch image grayce_api: getImageTags(...) must not be null"

I have 4 repositories in ECR, and this works fine for 2 of them but breaks for the other 2. It works when I put in the image name as “grayce_frontend” or “grayce_elasticsearch” but fails when I use “grayce_api” or “grayce_community_api”. The IAM user whose credentials I’ve provided in the Qovery registries definitely has access to all 4 of these repositories. I tried giving the IAM user wildcard access to all of ECR but that didn’t help. There is no real difference in how the repositories are set up in ECR. At this point I’m pretty stuck and unable to create applications.

FWIW, also setting this up is a bit confusing because the “Image name” field wants you to put in the name of what ECR calls a “Repository”. It would be a bit less confusing if the labels could change to reflect that for ECR repositories.

Hey @aubrey,

Sorry about that, can you please your Qovery console URL for this env so I can have a look?

Also, image tag is mandatory.

As per the image naming, I will loop back internally to see what can be done on that front.


@bchastanier sure, I’m at


After closer look, it seems your image name and / or full registry url for this image is wrong, it used to work because there were no checks on this before yesterday (we weren’t listing tags).

I see you’ve specified the repository name in the ECR URL setup. Can you try to remove it from there? The repository name / image name should be set in the container settings along with tag.

So at the end, you should have:

Can you try and let me know?

Actually, wait a bit, we will rollback this check, and will investigate to better handle this case.
I will let you know once rolledback.

:+1: I did try your suggestion and it’s still broken. Thanks for looking into it!

Hey @aubrey,

Fix has been released. It will try to fetch tags (has released yesterday) and if none are found (issue you had with your setup), it will allow you to manually edit tag.
You will see a warning message for next couple days and we will fix it properly backend side.

Let me know if it’s ok


@bchastanier Yes, that works! Thank you!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.