Allow creation of VPC Subnet with K3S clusters

Hey there :wave:

We had an issue while trying to deploy our sandbox & staging clusters. We used the terraform provider with the current configuration:

resource "qovery_cluster" "cluster" {
  organization_id =
  credentials_id  =
  name            = "Build Cluster"
  cloud_provider  = "AWS"
  region          = "eu-west-1"
  instance_type   = "t3a.medium"
  kubernetes_mode = "K3S"

  min_running_nodes = 1
  max_running_nodes = 1

  depends_on = [

And later, tried to add a project associated with this cluster:

resource "qovery_environment" "qovery_sandbox_environment" {
  project_id =
  name       = "sandbox"

  cluster_id =
  mode       = "DEVELOPMENT"

  depends_on = [

When planning the project creation, it seems like TF was trying to add a VPC Subnet even if it was not configured on our end:
CleanShot 2023-02-28 at 20.11.44

And it did not worked:

Later on, I tried to recreate a cluster with the subnet configured but again, it failed with the same error message:

So… I guess there might be an issue with the terraform provider and the VPC subnet when the mode is K3S. Everything works well when the mode is MANAGED. For now, it’s OK but we would like to switch our sandbox & staging cluster to K3S as soon as possible.

Let me know if you need any more data.

Hello Arthur,
indeed it looks like a bug since K3S doesn’t support VPC configuration. We will fix it as soon as possible.


Don’t you create a VPC for the EC2?

We do but VPC options are limited to EKS for now. Looking you error, K3S looks to have those default options while it shouldn’t.

Hello Artur,
we deployed a fix regarding your issue. It should work properly now.

Please let me know if it’s all good for you.