After deployment, why is there an error?

Issues information

  • OS: Win2000x64
  • databases: Sqlite
  • Programming language and version: Node-v12
  • Link to your project on Github/Gitlab: i use github, my github account is gordon518

Your issue
There is error after deployment.

Describe here your issue
There is a mark of “DEPLOYMENT_ERROR” on my hosting space. My hosting space is idate/idate/idate. Could you tell me what is the error? How to see the deployment error log?

By the way, before i set domain , the deployment works fine. But after i set domain for my hosting space, the deployment shows the DEPLOYMENT_ERROR mark.

Dockerfile content (if any)
FROM node:12
RUN mkdir -p /usr/src/app
WORKDIR /usr/src/app
COPY . .
RUN npm install
CMD node ./

Have you checked deployment logs? You can see them by navigating to your environment, and clicking “Show logs” (IMPORTANT - click show logs in ENVIRONMENT view, not application)

Thank you for telling me how to check the deployment logs. Yes, it is about domain, it shows as following. I have set the nameservers of the domain last night, it may take time to wait it in effect. Thanks.
--------deployment error log-----------
28 Jul, 15:16:49.401

Domain resolution check for ‘’ is still in progress…
28 Jul, 15:16:49.401


28 Jul, 15:16:49.401

Checking CNAME resolution of ‘’. Please wait, it can take some time…

Are there any other errors? I think the error with domain should not prevent the deployment to finish successfully

No other error, only the domain problem. The website can work, but there is the mark of “DEPLOYMENT_ERROR” on my hosting space.

The log.

This shouldn’t block the deployment, but have you set up CNAME correctly in your domain provider?

Yes, I have setup CNAME for the domain of i set “@” as host, and set “” as value in CNAME setup. Now I can access by a web browser. But why FireFox tells me the website of is unsafe? When accessing, FireFox doesn’t complain its security issue. Thanks.
The following is CNAME setup.

Hmm, where did you get the two values?

I would use only the one we provide - in Application → Settings → Custom Domain (copy-paste the value and put it in CNAME record in namescheap)

I have setup CNAME for the domain of Now I can access by a web browser. But why FireFox tells me the website of is unsafe? When accessing directly, FireFox doesn’t complain its security issue.Thanks.

Errors happen after deployment. The deployment logs show:
|02 Aug, 05:13:21.390||

idate WAITING Task is queued (32 tasks left) and will start when a worker is available.

02 Aug, 05:43:24.443

idate ERROR
Execution ID: ee1706ca-121d-445c-896c-c09b304c0efd-29-1627852400

Failed to get an answer from the engine in 30 min, aborting deployment. Please retry later !


This is an internal error from Qovery, when there is too many people on the community we fail your deployment after 30m of waiting in order to avoid overloading the system.
As the message ask, you can retry the deployment later when it is less busy.

P.s: We are adding more workers to the community version in order to reduce the wait time/this issue

Will the action of “retrying the deployment” clone everything from github again? I found the Sqlite db file reset after retrying the deployment. I hope to only update the files which i push to github.

Yes if you trigger a new deployment, it will create a new container image.
So the data you added in your sqlite file will be lost. You need to use some persistent storage if you don’t want this behavior (add a storage volume if the settings of your application)

Now google is blind for my website. How to let google know there is the website of ? Thanks.

Website down at ! But there is no error log. The page shows as following:

====Message Start=======
Secure Connection Failed

An error occurred during a connection to PR_END_OF_FILE_ERROR

The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
Please contact the website owners to inform them of this problem.

====Message End=======

Why is there this error message? Thanks.

It should be good now @gordon518