429 Too Many Requests on registry-1.docker.io


Relevant information to this issue:


We’re hitting 429 Error from Dockerhub when deploying our applications

#2 ERROR: failed to copy: httpReadSeeker: failed open: unexpected status code https://registry-1.docker.io/v2/hasura/graphql-engine/manifests/sha256:1bcd4c225e78d1638d9f52e6b7e75247ac5f39b40254996f2fb4254dd187ef3d: 429 Too Many Requests - Server message: toomanyrequests: You have reached your pull rate limit. You may increase the limit by authenticating and upgrading: https://www.docker.com/increase-rate-limit

1 Like

We’re getting the same error, seems like it must be a general Qovery issue.


To avoid the 429 you may want to create a container registry in your organization for DockerHub. This registry should have your credentials set.

Once done, when we are building the image, we first login to Dockerhub with your credential to avoid being rate limited.

You should see this message in the deployment logs

Let me know if it does not fix your issue

1 Like

Hey @Erebe , appreciate your response.

According to my understanding, it’s not us hit the limit, we don’t use previews. There’s probably a noisy neighbor that led Qovery’s DockerHub account to hit the limit?

I’d be curious about our own consumption

Yes indeed, the dockerhub rate limit rule is that unless you are logged/use creds, you are rate limited by your IP. So it may not be your workload that trigger the rate limit, but it contributes :see_no_evil:

Better create a dockerhub account, to allows rate limit to be specifically for your workload.

Understood, thanks👍

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.