Ssh'ing into kubernetes thru kubectl

Hello guys!

Im trying to ssh into my kubernetes to try and install a helm chart, im following this blog for it How to connect to your EKS cluster with kubectl | Qovery but im getting the following error

kubectl --kubeconfig=config.yaml get nodes
error: You must be logged in to the server (Unauthorized)

This is my first time doing this and I honestly have no clue whats happening here. My IAM user has the samer admins permission and I have updated the kubernetes config file so it work with aws-iam-authenticator@0.5.9 (which i believe had a change of api version)

At the end im trying to install the new-relic helm-chart thats why im following the datadog guide as i know they are pretty similar

Ok, now I was able to connect. The problem was some misconfiguration, basically aws-kms only lets the cluster creator to connect, so I basically just connect with those keys (which i honestly don’t like) there seems to be another option to connect but i have not been able to properly configure it. You could probably connect by using sts:AssumeRole on AWS, kinda makes sense but i have yet to properly configure it and connect, i think the blog should probably be updated to account for the changes in aws-iam-authenticator

Hi,

Today, if you want to be able to connect, the IAM user you want to be able to connect to your Kubernetes cluster should be inside the “Admins” group (case sensitive).

sts:AssumeRole is something we consider and should be available in the coming months.

Pierre

1 Like

Oh, so the IAM group should be named literally Admins? I guess thats part of the error as I have my qovery group as qovery-admins