Increase the 60s default nginx timeout

I have a particular api endpoint that can takes time to respond and in some cases needs more than 60s. However, the nginx server managed by Qovery returns a 502 bad gateway as the timeout is set to 1min. Would it be possible to increase them through your api like it’s currently possible for body size?

proxy_connect_timeout       XXs;
proxy_send_timeout          XXs;
proxy_read_timeout          XXs;
send_timeout                XXs;
2 Likes

Hi @auree , I think it’s planned very soon to support those options. Can you confirm @Pierre_Mavro ?

@Pierre_Mavro could you give us an ETA please? :pray:

Hi @auree , it will be available this week :slight_smile:

1 Like

@auree new features are now available to better control websockets :slight_smile:

Please find advanced features here: Advanced Settings | Docs | Qovery