Getting `InvalidInstanceType: The following supplied instance types do not exist` regardless of what instance type I supply

I am trying to update an existing K3S cluster. Regardless of what instance type I supply, I keep getting the following error.

I am verifying that instance type exists on ec2 pricing page. In this example, I am trying a c5a.xlarge and I get the error.

I have been trying this for a few hours now with various instance types, and I get the same error.

Hello @r4881t,

Sorry to hear that. We plan to enforce instance type per region in coming weeks.

From screenshot showing log error, it seems that instance you picked (c3.xlarge) is not supported in the region you choose ap-south-1.

You can check supported instance per region via this AWS CLI command =>
aws ec2 describe-instance-type-offerings --region ap-south-1

We have a list on our end which is supposed to stick to AWS offering => engine/ at main · Qovery/engine · GitHub

You can either change region if doable on your end or pick another instance type.

From your message, it seems you tried with c5a.xlarge which is supposed to work on AWS in the given region. Do you have the same error message?


Maybe I am not clear. Irrespective of what instance type I choose on the console UI, the logs always show c3.xlarge. In this case also, I have chosen & saved c5a.xlarge from UI. However when I click on “Update” I see logs with c3.xlarge

 $ aws ec2 describe-instance-type-offerings --region ap-south-1 | grep "c5a.xlarge"
            "InstanceType": "c5a.xlarge",

Hey @r4881t !

Ok, after digging it seems to be a bug on our end, seems EC2 cluster struggles to be changed after creation try (Terraform issue). I will fix it for you, just tell me which instance type you want for this region?
Also, can you confirm this cluster is a new one and has never been deployed?


Hi @bchastanier I want it on c5a.xlarge instance.

Should be all good now, cluster up and running.

Yes it is. Thanks for the quick resolution.