Direct remote connection to DBs

Hello guys,
Are DBs public accessible? eg. remotely connect using DBeaver* to a qovery pgsql db
* (DB GUI tool)

The UI indicate that they are (“public” config option), but I am unable to connect.

I tried using the value of these env vars:
QOVERY_POSTGRESQL_ZC2xxx_HOST
QOVERY_APPLICATION_Z85xxxx_HOST_INTERNAL

Which are in the format:
zc240xxx-postgresql.Q_DOMAIN
and checking logs I saw the value of Q_DOMAIN and the final URL as: zc2xxxx-postgresql.qovery.io (which I am effectively using in DBeaver config)

also trying Q_DOMAIN as qovery.com or myappdomain was not successful.

Assuming that could be an issue specific to DBeaver I also tried to connect directly over some tcp/socks directly to the ports and it failed. Apparently my host/port pair is wrong or DB is not open.

Am I missing something?

Thanks

you can use the Credentials given on the DB settings page, there you will find host, port and user credentials.

Try connecting with postgrecli, if that’s not working then issue on the qovery side, i guess.

As Kartik suggested, try connecting using credentials listed here (screenshot) and a Postgres CLI client first.