Updating project for custom domain

Issues information
I’m just down to trying to get my project updated after committing .qovery.yml at Github to include a custom domain. There is a webhook for qovery. It’s my impression that my project should be automatically updated but it hasn’t been. I’ve tried restarting.

  • OS:
    I’m working on a Windows 10 laptop.
  • databases:
  • Programming language and version:
    JavaScript on nodejs. Application: peerjs
  • Link to your project on Github/Gitlab:
    GitHub - highlevellogic/peerjs-server: Server for PeerJS
  • Docker file
    FROM node:alpine
    RUN mkdir /peer-server
    WORKDIR /peer-server
    COPY bin ./bin
    COPY dist ./dist
    COPY package.json .
    RUN npm install --production
    EXPOSE 9000
    ENTRYPOINT [“node”, “bin/peerjs”]
    CMD [ “–port”, “9000”, “–path”, “/myapp” ]

@rogerfgay can you confirm that you still have the issue? @Enzo will help you in a few hours.

1 Like

Yes. I still have the issue. In addition:

qovery domain list -p peerjs -b main
Resource not found! Have you managed to successfully deploy your environment before? Try forcing a new deployment by pushing a new commit and watch the status using qovery status --watch.

Can you try to run the command qovery domain list while you are at the root of your project?

How do I do that?

qovery version

SUCCESS: Guessing a bit about how to do that (I’m new to some of the tools and things), I cloned the git repository and ran qovery environment list
←[31mERROR←[0m: Your .qovery.yml is in a bad shape.
←[32mSOLUTION←[0m: Are you sure to have a .qovery.yml file? Verify the content.

YAML is one of those things I don’t know much about - but figured out that I needed to indent the “custom domains:” line; then committed the change using the git CLI.

Then running “qovery domain list” in the same directory gave the expected response.

.qovery.yml listing in Qovery has been updated and there is a new listing at the bottom of that page showing the custom domain.

Verification process might be taking too long; would like second opinion on being patient. Might work, but:
I had created the CNAME too soon, using the public URL for the app. It had propagated before I submitted the yml file correctly. I have recommitted the yml file with the same information just to see if it would trigger something.

Should I wait it out, or do you think I need to take measures – for example: Should I resubmit the yml file without a custom domain to delete it and then repeat the whole process?

Now I’m confused again. qovery domain list says status: VERIFYING
But the custom domain works now via https.

OK, maybe I’m not so confused, except for the https part. I guess I am still confused.
If I understand; having a custom domain is the only way to get https.
So, if my CNAME pointed to the public domain (see comment above), it would work on http but not https.
To work on https, the custom domain needs to be verified, but qovery domain list seems to be telling me that it hasn’t yet: “VERIFYING”

My app is working, so maybe the fact that it still says VERIFYING is a bug?
Anyway - I’m good.

A day has gone by and “qovery domain list” STATUS is still “VERIFYING”.
As noted above, my app works. Things are good for me.
But as a newbie here, I’m asking for second opinions on whether I should file a bug report.
If I don’t get any responses, I probably will. But don’t want to bother the dev group if this isn’t a bug.

Hey, yeah indeed it’s a bug on our side. It will be fixed in the next major release. Thanks for the report!