Unable to delete clusters


I am trying to remove/delete our clusters and getting the following error.

DeleteError - Error, resource EC2 Internet Gateway igw-01f30ea8503ad7446 has dependency violation.

Dev Cluster

Cluster ID: 16f54f13-88a7-4311-845e-179f14e0f712
Exec. ID: 7c9ed7ae-a46c-461c-b509-d875665b84f1-1683192288
Org. ID: e2434c8e-0905-4969-9536-670f9a774f44

Production Cluster

Cluster ID: ebbeccf5-bdf7-417d-a1df-8fa84fec079e
Exec. ID: 6fe50a72-0317-4d55-b853-3e3940b1d3f8-1683192706
Org. ID: e2434c8e-0905-4969-9536-670f9a774f44

Could you please take a look at this?

Hello @Rahulkhanna26 !

It’s due your cluster has a dependency we cannot delete. Here it’s the internet gateway. Do you have a VPC plugged to it?

Here’s error on your dev cluster:

Error: error deleting ElastiCache Subnet Group (elasticache-vpc-0c2c112392b9488da): CacheSubnetGroupInUse: Cache subnet group elasticache-vpc-0c2c112392b9488da is currently in use by a cache cluster.

and on your prod cluster:

Error: error deleting ElastiCache Subnet Group (elasticache-vpc-0d9f436f3804929ee): CacheSubnetGroupInUse: Cache subnet group elasticache-vpc-0d9f436f3804929ee is currently in use by a cache cluster

So you should delete manually your VPC from AWS console.

You can have a look to this post => Cluster stuck in deletion state - #3 by bchastanier



Thanks, I have tried to delete the attached VPC but I am currently stuck as I can’t find where I can unmap the auto-assigned public IP address.

VPC is currently mapped to which is I think assigned from Qovery. So, when I try to delete the IGW then I am being asked to first unmap this public IP.

That’s a good point, I’ve never tried to unmap it via Qovery, you can try actually , unmap it, deploy the cluster and then trigger a delete (deploy might not be necessary as delete triggers a deploy first to align all resources).

Otherwise, you should have a view in console to see all subnets and connections on a VPC, it’s in the VPC details view => in my case /vpc/home?region=us-east-2#VpcDetails:VpcId=vpc-0d536128abf28ebe5


You can also use this technique to find desired resources: Troubleshoot | Docs | Qovery


@bchastanier Thank you! Managed to delete the clusters after deleting the VPC and unmapping the public address.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.