Unable to clone environment correctly

Hi,
We are trying to migrate our preproduction environment from EKS to EC2 K3S by cloning through v2 console.
It seems deploy of our application “Backend” seems not working correctly. Port and Domain are defined correctly. But generated url doesn’t provide our application :
https://zf00922f0-z804898ba-gtw.zdd3d991a.helpers.sh/

Could you help us resolve our problem?

Thanks
Jérémy.

Hello,

Can you provide us the console.qovery.com link toward your environment so we can take a look at it

thank you :slight_smile:

thank you, I am taking a look at it

Hi back @JrmyDev,

Should be good now, we made a bad release where we were not correctly settings the DNS records for EC2 instance.
I have redeployed your instance and now your app is reachable.
https://zf00922f0-z804898ba-gtw.zdd3d991a.helpers.sh/

BTW, with all the applications you are going to deploy, your EC2 instances will be low on resources.
I recommend you to use at least the double.

Thanks,

We have lot applications but those are small microservices which need small cpu and ram.

For K3S EC2, we should refer to aws on demand ec2 or spot pricing ?

@Erebe we always have conflict error with previous environment (Qovery Web Console | Deploy and Manage On-demand Environments on AWS, Remarkably Fast)

DNS is not setup properly https://zf00922f0-z804898ba-gtw.zdd3d991a.helpers.sh/ (new environment) while redeploying backend on new environment), instead, it deploys DNS on old url

Hello,

I am not sure to understand.
From what I can see:

  • Preproduction environment is running on eks cluster named “aws”
    This cluster own the domain name “*.z2d385c53.rustrocks.cloud”

  • Preproduction-clone environment is running on ec2 instance named “Preproduction”
    This cluster own the domain name “*.zdd3d991a.helpers.sh”

All environments deployed on the ec2 instances are going to be mapped to an url with xxxx.zdd3d991a.helpers.sh

Cloning the environment from one cluster to another is not going to keep the previously generated url (new ones using the domain of the cluster will be used)
Also, if you have custom domain from the previous environment, you need to add it also to the new environment and update your cname accordingly.

Let me know if I am missing something

We have a custom domain previously setup in previous env. Then we delete and stop env.
After setup domain in new environment and editing dns, it’s not working. It seems there is conflict with old generated url

Hello @JrmyDev

You need to update the cname of your domain to the one specified in your application settings.
At the moment, it is still pointing to the old cluster/cname.
Updating the cname for api.preprod.welco.io can only be done by you at your domain registrar. We don’t have the hand to edit/set it

api.preprod.welco.io should point to zf00922f0-z804898ba-gtw.zdd3d991a.helpers.sh

I already did this since hours (our TTL is 60sc)

@Erebe it’s resolved now. It seems there was an issue setting cname on OVH. I delete cname entry and set again.

Thanks for your help