Subprocesses kills the main (active) process

I run a dockerised python app on qovery, which is capable of executing small python commands in a subprocess, or by using os.system. Doing this on qovery, always leads to it killing the main process.

Eg: running speedtest-cli --simple in a subprocess, would lead to


(pyUltroid, refers to the main process with which the app is run, i.e, python3 -m pyUltroid)

I guess this is a bug. I faced similar problems on using os.system(..) in the main.py of my app, while deploying it too.

Hello,

Can you give me the URL of your application (the one from your browser starting by console.qovery.com) so that I can take a look please ?

Sure. Here.

Btw, the issue comes only when i run a subprocess…

Hello,

The issue is that the application is very close to the maximum limit of memory, and if you request too much, it is going to be killed due to be out of memory.

You can increase the maximum allowed memory for your app in the settings (you need to re-deploy/restart to make the change effective), but we cap community application up to 512Mb

Oh. So this means the ram is auto locked to 250mb, by default, and we must manually increase it (upto a maximum of 512mb) to prevent crashes, right?

That’s right :slight_smile:

But if your app tries to request too much memory beyond 512Mb it is going to be killed also

Oh! Okay. Thanks for the info