Solved: Can not redeploy app, delete it, delete env, delete project or even cluster

Hello guys,

I wanted to update my infrastructure using terraform. All went fine except for one application (id 38caea73-c690-49d0-8e25-221678617124).

First it showed “Deployment error” but in the deployment logs I could not find any errors. So I tried to redeploy the app via the web console. Didn’t work either.

Then I tried to delete the app. Also did not work. I tried to delete the environment, project and cluster … all of that did not work.

I then tried to delete the organization. This did work, but not a single resource in my AWS has been deleted.

Can you help me? :sweat_smile:

Best,
Pierre

Hi @hedgehogs-mind ,

As mentioned in the Troubleshot guide:

Unfortunately, there is no automatic way to do it with Qovery once we don’t have access. However, AWS provides an easy way to retrieve those resources, so you can manually perform the delete. To do so, go on the AWS web console, and search for “Resource Groups & Tag Editor” service, then:

  1. Click on “Create Resource Group”.
  2. In Tags, enter: “ClusterLongId”.
  3. In the Optional Tag value, enter the Qovery cluster ID. If you don’t have it, let AWS suggest it for you. If you have Qovery deployed elements remainings, it will propose the Cluster long ID automatically.
  4. Click on “Add”.
  5. You should see the filter with the information you just entered.
  6. Click on “Preview groups resources”.
  7. You’ll have all elements deployed by Qovery and you can delete what you want.

Pierre

Thanks Pierre for the hint!

Thanks to this I was able to delete all AWS resources :heart:

Best,
Pierre

1 Like