MongoDB not reachable

Issues information

  • OS: Windows 10 x64 (Not sure how this is relevant)
  • Databases: 1x MongoDB
  • Programming language and version: Python 3, latest

Your issue
MongoDB is not reachable.

Describe here your issue
MongoDB is not reachable from my machine using MongoDB Compass.
It worked before but stopped about 1 day ago. Not sure if my py app can access the DB, because the log has gotten so long that it times out before it loads. I tried downloading the log, but that doesn’t work either. The status on the Qovery website says “Running”, but I can’t confirm that.
I do know that the app ran before when I could still see the log.

Dockerfile content (if any)

FROM python:latest
COPY ./app .
RUN pip3 install -r requirements.txt
CMD [ "python3", "" ]

Hi @Feriixu, welcome to the Qovery Community :slight_smile:

So it was working, and it stopped working suddenly? How did you connect your app to your MongoDB database?

@Enzo, can you take a look and help him to fix this issue? Thank you buddy.

Hi @rophilogene,
I’m using the pymongo library to connect to the database from my app, but I can’t check if the app is still working, because I can’t see the logs. It has worked before though.

The core issue is, that I can’t connect to the MongoDB with the MongoDB Compass Client on my Windows Machine, because it isn’t reachable. (Has worked before too)

I’ll take a look and try to find what’s going on

After investigation, it seems that your database is full (10 Gb limit). Here are the option we can propose:

  1. Send you a dump to help you clean unwanted data, then we flush the current content and you will be able to restore the cleaned data.
  2. If you already have a backup of your data, we flush the db content and you restore it.
  3. You don’t need the restore anything and we just flush the db.

Let us know what suits to you.

I was already suspecting a limit, but I couldn’t find it anywhere on the website.
Please send me a dump of the data. :slight_smile: