Manual Trigger for Preview Environment doesn't start


Is there any additional steps to correctly enable Manual Trigger for Preview Environment feature? I followed the tutorial, opened new pull-request, got message from Qovery bot about available Preview Environment, but when I post a comment with suggested command, just nothing happens.
If I turn off “Create on demand” and create new PR, everything works fine. We use Github.

Hello @km1414,

Yes this should work.
Can you share me the git repository impacted so I can investigate internally ?

Thank you

Can you retry to configure your preview environment rules by:

  • force-enable the “Turn on Preview Environments” (uncheck & check it if it’s enabled)
  • force-enable the “Create on demand”
  • disable the services as you desire
  • click on “Save” button

Then, can you re-test the manual preview environment trigger with a PR ? I think this should work.

Hm, I tried to uncheck & check & save multiple times, but that didn’t change anything (with new PR I get the initial info message, but posted command doesn’t trigger Preview Env). Any other possible solutions?

Can you send a screenshot of the message generated & your comment ? (as the first screenshot in the first comment)

ID: 083cf472-d987-4553-9b25-f6447862c739

Thanks @km1414
I don’t see any trace of your comment on our side.
Can you look at your repository settings if you have the “Issue Comments” checked, in the “Webhooks” section.

@Melvin_Zottola Yes, that helped, thank you.

Hi @Qovery_Team , we have a new problem - this time Preview Environment works for me, but doesn’t start for my colleague. Could you please check whats’s wrong here?


I am going to take a look at it.

Hi back,

So I took a look and we only received the comment you made @km1414.
Can you go in the settings of your repository → webhhoks → qovery one → recent deliveries
and give me the list of events that concerns issue_comment.created with the body payload, the headers and the response if it is not 200 please.

With that, I will be able to see if we are missing something.

Hi, thanks for your help. We found the issue and it works now. It turns out that my colleague was trying to start Preview Env not by directly writing comment, but via PR Review flow.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.