Issue creating an Application in a Project (Python 3.8)

Issues information

  • OS: Manjaro Linux
  • databases: postgres 12
  • Programming language and version: Python 3.8
  • Link to your project on Github/Gitlab: GitLab

Your issue

I cannot create an application from the above repository, because I keep hitting a 504 Gateway Timeout. Everything up to and including adding the .qovery.yml configuration works fine, then the API returns a 504 Gateway Timeout (Response Headers), and nothing happens. Application is not created.

I’ve tried to create via a different browser (Chrome, Opera, Firefox, Vivaldi), on different machines (windows,linux, I even borrowed a colleagues MacBook…) and on different networks (Work, Mobile, even via SSH on my home network). And the console behaves like this in all possible combinations of the above.

I can’t find any application linked to you gitlab account deployed in Qovery, did you delete it ?

That’s the issue! I cannot finish the process creating one. Been hunting this one down for the weekend…

-EDIT- Let me rephrase the issue: The project itself has been created, now I want to add an application. I linked my gitlab account, since it holds my source code. So far so fine, I get to pick my repo, add the database, and see the summary. Everything is okay, so I hit deploy… which shows the spinner for a few and then throws an error in my direction which I don’t see for more then a second. So I open up the Inspector and hit “Deploy” again, this time seeing the request erroring out with HTTP Error 504 as linked above.

1 Like

In order to make some test, can you tell me which of your gitlab repository you use ?

It’s the one I linked above.

Just in case:

Does the repo linked contains a qovery.yaml file ? If yes, can you delete it and try to redeploy your app ?

It did. Deleted it. Tried again.Behaviour is still the same.

Although I only tested from my phone right now…

Any news on this? I’m working on a feature here I want to test w/ this rather soonish

we’re facing an issue with gitlab accounts. We’re looking for a quick solution.

@Kaltenstein23 could you check if in your Project → Settings → Webhooks there are Qovery webhooks enabled?

EDIT: I see the last error related to your repo on our side. So it means webhooks are enabled. The error is:

Cannot fetch application config for oauth2|Gitlab|8644843 Mercury One/master from 7ad8bb72172f61ce6100d88f8b03d2e85f39d504

Could you confirm that the commit ID is correct? And that there is a .qovery.yml in your repo with this commit?

Can confirm a commit with this ID exists and contains a .qovery.yml

So, I finally went, nuked the repo, pushed again, now it works. :man_shrugging:

1 Like