Invalid Scaleway credentials: null

INFORMATION

Link to service : Qovery

ISSUE

We are migrating from the Scaleway container registry to GitLab container registry (thank you for this new feature!).

When I setup the service to use the GitLab container registry, then deploy manually it works perfectly.

But from the CI/CD pipeline I’m deploying with a POST request to the API :

curl -X POST -f \
-H "content-type: application/json" \
-H "Authorization: Token $QOVERY_API_TOKEN" \
-d "{\"image_tag\":\"$CI_COMMIT_TAG\"}" \
"https://api.qovery.com/container/$QOVERY_SERVICE_ID/deploy"

I’ve been doing this for months without any error when I was using the Scaleway container registry, but when I try to do the same thing with the GitLab container registry settings, my deployment logs only show this error :
image

I checked everything multiple times, recreated the service from scratch, but nothing worked. Manuel deployment work, deployments using the API throw this error.

Then I tried to create a new Scaleway CR, or redeploy containers stored in the Scaleway CR, but I have a toast saying the same kind of error :
image

I looked through the forum topics and google, I didn’t find any information that could help me solve this problem.

Until yesterday everything worked fine, I was able to deploy from Scaleway CR.

HOW TO REPRODUCE

  • Create a service using a GitLab container registry
  • Deploy manually → it should work
  • Deploy the service using API → error “Invalid scaleway credentials: null”

OR

  • Create a new Scaleway CR registry or edit an old one → error “Invalid Scaleway CR credentials: null”

Hello,

Thank you for the detailed explanation.
I am going to look at it, and will keep you posted.

Thanks for the report :slight_smile:

Hi back,

It should be fixed. Scaleway changed the way they authenticate.
Would you mind letting me know if it’s ok on your side ?

Yes, it works perfectly fine. Thank you ! :pray:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.