Helm deployment file not being mounted

ENV link: Qovery

I have mounted tls certs for temporal in variables, I am deploying the service via helm, when I cd to the etc directory I don’t see this file mounted at the required path.

Can you help ?

Hi @saadhypng , can you list here all the variables you tried to mount please? Can you explain what you saw that makes you think that they are not appropriately mounted? The more details you share with us and the better it is for finding the root of the issue :pray:

@rophilogene So the variables I tried to mount are,
TEMPORAL_TLS_KEY
/etc/temporal/temporal.key
TEMPORAL_TLS_PEM
/etc/temporal/temporal.pem

Also, I verified by running exec into the container and verifying this path and the data was not there.
In the meantime, I have manually created the secret in the namespace and then changed the helm chart to have mounted volumes and created the files via that.

Also one more challenge I am facing with Helm , I went through the docs can you provide more information on how to use macros for env var replacement I have added those but all variables are being added to values file are base64 encoded.