First deployment failed

I tried to follow the tutorial to launch a first app using a fork of the GitHub repository: GitHub - metabase/metabase: The simplest, fastest way to get business intelligence and analytics to everyone in your company
I specified to build from: metabase/Dockerfile at master · metabase/metabase · GitHub
Unfortunately, the deployment failed:

:x: Container image failed to be built: Cannot build Application “z397f5a1f” due to an error with docker: ExitStatusError { exit_status: ExitStatus(unix_wait_status(256)) }
05 Jun, 16:07:36:58
:bomb: Deployment failed

Do you happen to know what the issue might be?

Thank you in advance.


Hey @Louis,

Do you mind sharing your console link to your app so I can have a look?

Thanks !

hey @bchastanier,

Is it the link you had in mind ?

Thanks !

Looking at your aplication config, I am wondering why you set Docker arguments to be ["3000"]?

From documentation, I am not sure it’s needed.

Port 3000 is already configured in ports section so I think it should be good.

Can you try to remove those arguments and try to deploy again?

1 Like

Thank you for your answer Benjamin.

I removed the CMD arguments and redeployed. I still have the same issue in the logs:

❌ Container image failed to be build: Cannot build Application "z397f5a1f" due to an error with docker: ExitStatusError { exit_status: ExitStatus(unix_wait_status(256)) }


07 Jun, 17:43:58:94

💣 Deployment failed

Here is the link of the logs of the last deployment.



Issue seems to be building the image, did you try locally to build and run it?
If so would you mind sharing the command line you used?

ERROR: failed to solve: process "/bin/sh -c INTERACTIVE=false CI=true MB_EDITION=$MB_EDITION bin/" did not complete successfully: exit code: 255

No, I didn’t built it locally. If it helps, I built it directly in AWS using an EC2 instance 2 years ago or so. I remember I used the official Metabase Docker image on Dockerhub.
May be I don’t use the correct way to build Metabase with Qovery. Can you investigate and let me know what’s the right way of deploying this app ?



Just tried to deploy metabase from official image and it works perfectly.
May I ask why do you have to build it from your repo instead of using its official image?

Here’s my config:

You just need to add docker hub as registry to your organization:


Thanks a lots

I actually just followed the tutorial that suggests to start from a GitHub repo.

It indeed works great using Docker directly.

I have an additional question: deploying an app on several instances will create several links. Does Qovery integrate a load balancer to redirect seamlessly users ?



Great !

Several instances will be behind an nginx and it will be transparent for users.

I am not sure to understand this one, but if you meant application URLs, it won’t generate several URLs, everything will be behind one (or several if you add custom domains), but in anycase, you won’t be able to target one or the other instance, it will be transparent.


Sorry, here is a screenshot that is hopefully more clear and sumps up my question:

Ok !

Those links are not linked to number of instances, but to ports.
Even those URLs will balance traffic to several instances transparently.

Hope it answers to your question.


Yes, thanks a lot for your answers.
Last but not least: when I click on any of those 2 links (for example this one), Metabase is loading. It’s been like that since the deployment which is very strange.
I’ve found this github thread about kind of the same problem. They suggest installing haveged.

Can you look into this bug please ?
Thanks !

Hey @Louis,

Just went to your app and it’s loading just fine here.
Regarding your entropy issue, I am just not sure we (Qovery) can do anything about it for you. I am not sure if changing your cluster instance type will fix this issue but you can try.

From my stand point, your app is running and deploying, from there, there is not so much I can do, I am not familiar with Metabase, and cannot give you more help than what they have in their documentation.

Happy to help on other matters :slight_smile: