DEPLOYMENT_ERROR : Trying to Deploy Meilisearch app v2

I’m tring to set up an app to test Meilisearch without success (v2).
The other version (v1) had a template to do this more easly.

First I Create environment, then Added my first app with git repository with one file called Dockerfile with this content :

FROM getmeili/meilisearch:latest
EXPOSE 7700

After that the app was created.
I setup the setting for the app (ram and storage) :
image

When deploying i get this error : DEPLOYMENT_ERROR

Hi. Welcome to the qovery forum. Here we’ll try and help you troubleshoot your issue so you can successfully deploy your application.

Can you please make sure that the port config is also saved on the qovery console? You can do that by going to the settings app, then ports, then configure the correct port.

If that doesn’t work, let me know. For now there are no guides for deploying meilisearch on the V2 but they will be updated soon.

Yes , the port was already set.
I could not post the picture in the first post because on create says : new user cannot post more than one picture in the same post.

url : https://ze65a6952-gtw.qovery.io/ : default backend - 404

@Pierre_Mavro can you take a look?

Can you restart your meilisearch app?

Yes, restarted now, same error. :frowning:

Hello bruno,

Can you give me the url of your environment so I can take a look please ?
It Is the one that start by console.qovery.com

Thanks :slight_smile:

Hello

Hello,

Sorry for the late response, after investigating your case it seems we have a regression with custom domain in the V2.

It is going to be fixed tomorrow or next week if time is short.

I am going to keep you updated regarding the evolution.

Sorry for the inconvenience :frowning:

Thanks,
If its a «new account» it works right ?

Similar Error build fails with this MESSAGE FOR QOVERY TEAM:
* Execution ID: 3281ae53-1f7b-4f5a-b319-a2281cb443f3-2-1626423235
* Scope: Build platform ‘beta-build’ with id ‘ze9e19029’
* Rollback message:

Last success command container beta-build (ze9e19029) is built

Hello Bruno,

You seem to have misconfigured your application.
In order to build it with a Dockerfile (instead of the default Buildpacks) you need to go in your application setting and change the build mode (as shown below), and after saving, restart your application for the change to be applied

After this change and re-deploying your application, it’s now running perfectly
ze65a6952-gtw.qovery.io :slight_smile:

I did not see that :confused: sorry
Its up and running, but its slower than the v1.

Thanks.

You can increase resources (cpu/ram) in the application settings.
(But community version is limited regarding the amount of resources it can consume)