Database Deployment

  • OS:
  • databases: MySQL
  • Programming language and version: Node Js

I had deployed a Strapi App using the template.The Application was deployed successfully and running but the Database still shows as Deploying. I can make changes to the database even though it shows as Deploying

Deployment logs -

2021-06-28T18:32:26Z DEPLOYMENT_IN_PROGRESS APPLICATION INFO check deployment application strapi

2021-06-28T18:32:26Z DEPLOYMENT_IN_PROGRESS APPLICATION INFO check deployment succeeded for application strapi

2021-06-28T18:32:26Z DEPLOYMENT_IN_PROGRESS DATABASE INFO check deployment mysql database my-sql

2021-06-28T18:32:26Z DEPLOYMENT_IN_PROGRESS ROUTER INFO check deployment succeeded for router main

2021-06-28T18:32:26Z DEPLOYMENT_IN_PROGRESS ROUTER INFO check deployment router main

2021-06-28T18:32:26Z DEPLOYMENT_IN_PROGRESS DATABASE INFO check deployment succeeded for mysql database my-sq

FROM strapi/strapi:3.6.1 WORKDIR /app COPY ./strapi-app . COPY .env .env RUN yarn RUN yarn build EXPOSE 1337 CMD ["strapi", "start"]

Hello @SuyashMuley !

First of, thanks for using Qovery :slight_smile:

While having a look, I do see the DB deployment as successful, seems to be up and running since 2021-06-28 18:32:27.045 UTC time.

Are you able to properly interact with your application and DB?

We suspect it might be a display bug showing the DB still deploying while it’s up and running.

Please let me know.

Cheers !

Thanks for the help Yes I can interact with Application and DB.
I guess it’s a display bug.

Alright, I am creating a thread internally to get this fixed.

Thanks a lot for contacting us and sorry for the convenience :slight_smile:

1 Like