Connecting to Managed Redis instance from Ruby Web App

Hello @rophilogene and team:

We are still getting an error regarding authorization required with the Redis managed instance we spun up. Any estimate on when we are able to move our Redis instance out of container setup (current workaround) to Managed?

022-04-13 23:46:58 UTC | CORE | ERROR | (pkg/collector/worker/check_logger.go:68 in Error) | check:redisdb | Error running check: [{“message”: “Authentication required.”, “traceback”: "Traceback (most recent call last):

Hi @sama213 , the fix is in progress. @Enzo will ping you back when it’ll be released. Thank you for your patience

1 Like

Hey @rophilogene , @Enzo, any updates on this? Thanks!!!

I encounter the same issue trying to connect my nodejs backend to a private managed redis instance on production.

I also tried what qovery team member mentioned in this thread by not supplying the password but it doesn’t seem to work.

Is there any updates?

Hello there,
sorry for the late response. So here are the things to know about managed redis auth:

  • If you’re using v5 manged redis or the old fashionned v6 (deployed before july), you don’t need to use the password since auth password isn’t handle by those versions
  • If you’re using the new managed v6, you have to use the password AND enable TLS for the connection. Since enabling auth for this version means enabling encryption, this is mandatory to set them both. This topic said a bit more.
1 Like