CNAME check doesn't work with CDN

When using a custom domain with CDN like Cloudflare, the router tries to check the CNAME record and fails with a message: “Cannot find domain under CNAME <…>. Retrying in 5 seconds…”

After multiple failed retries it tells “If you are using a CDN you can forget this message”. However, it hangs the deployment process for ~3 minutes. Is there a way to disable this?

Hi @prki , we can add a feature flag in the app advanced settings to disable the check-in case of using a CDN. Let me see with @a_carrano next week.