Cloning an environment with lifecycle job errors

Cloned my enviornment with a lifecycle job and when the lifecycle job tried to deploy this error came up:

Error: rendered manifests contain a resource that already exists. Unable to continue with install: ClusterRole "aws-cloudwatch-metrics" in namespace "" exists and cannot be imported into the current release: invalid ownership metadata; annotation validation error: key "" must equal "env-z44ba7b40-XXXX-XXXX": current value is "env-zcc81b95d-XXXX"

All I did was clone the enviornment. Anything that needs to be considered here in regards to life cycle jobs?

Just to move things along I tried deleting the lifecycle job but since it never installed correctly it also couldn’t delete correctly… not sure how I can get this to deploy now.

Hello @kincorvia,
Could you share your web console URL to check this?

Did the initial env and the cloned environment where is the same cluster?

Is this case, yes they were

As it’s seems that this job should be unique in a cluster, it may be better to move this kind of job in a dedicated environment to setup the cluster. Do you want I tried to delete this job from the stripe environment?

I had a similar thought but i wasn’t sure what the recommended path for that was. I was thinking you should enable lifecycle jobs for the cluster but it makes sense to set them up in a separate environment. I can do that yes. Can you please delete the job from the environment so I can proceed with your suggestion? Thank you!

I’ve triggered again the deletion and your job has been deleted. I need to check why you can’t delete the job yourself.

Thank you @Pierre_Gerbelot